Arbor Site issues

Incident Report for BDMAT IT Services

Resolved

Arbor now reporting as fully operational.
Posted Sep 10, 2026 - 11:36 BST

Investigating

Arbor is currently experiencing issues
https://status.arbor-education.com/
We will monitor to ensure that you are alerted as soon as it is back up and working.
Posted Sep 10, 2026 - 11:11 BST
This incident affected: 3rd Party Services (Arbor MIS).